Garmin nuvi 660 updating bluetooth firmware

Rated 4.5/5 based on 849 customer reviews

Just got the new version (4.70) installed on my nuvi and so far so good. (LOL) One question, I have the ORIGINAL Bluetooth software on the unit, it shows as version 00.00 on the unit. I discovered that the FM traffic service didn't report any incidents, just a couple of construction zone locations. Movie Thtr 10.04 9.17 They stated the new version: Added support for one traffic provider Improved Points of Interest searching May be worth it just to improve POI searching.

My question is, should I install the new bluetooth version or just leave things be since it seems to work fine as it is?! It had been snowing overnight and I knew that there should have been some accidents and the odd road closure reports for my area. I use that a lot so want to take advantage of improvements they made.

--Nuvi 660 -- and not upgrading it or maps until Garmin fixes long-standing bugs/problems, and get maps to where they are much more current, AND corrected on a more timely basis when advised of mistakes.

Just got the new version (4.70) installed on my nuvi and so far so good. (LOL) One question, I have the ORIGINAL Bluetooth software on the unit, it shows as version 00.00 on the unit.

Have you recently connected your nuvi to the computer and updated the firmware?

So for me the traffic services didn't seem to work as well after the "upgrade." Anyways I decided to revert back to v. No problems encountered for the upgrade from 4.60 to 4.70 There is little difference in POI search times as claimed in "Improved Points of Interest searching" bullet in release notes. I would expect someone at Garmin monitor's POI Factory (as I consider Factory to be the best) and probably implement some discussions we have read about.

go to the direct software update link: - Download: Nuvi 660 software update version 4.70 (4.86 MB) as of December 11, 2008 Thank you, thank you for sharing the info on holding power button down.

I just updated my Nuvi 660 from v.3.5 to v3.6 software and got the error message. Your procedure worked great,had the "System software missing" after a Webupdate_241.

Yes, it took at least 60sec for pre boot mode to disappear but once it did, unit was back to normal with v3.6 OS. I was on Wi Fi late at night with very good speed,it all took only about 5 minutes.

When I tried to do it again, I got the message that the 670 was already updated,tried to update again,got the message"The update file is corrupted".

Leave a Reply